Adobe et Maverick

java-logo-100x100
logo java

Mac OS X Maverick est sorti, il est gratuit et tout joli, il s’installe sans un bruit. Tout va bien…

Ou presque (car Maverick, comme Lion et Mountain Lion d’ailleurs, est livré SANS machine Java, mais ça, je ne m’en souvenais plus).

Ce matin, j’essaie d’ouvrir une image sous photoshop 5.1 et boum, le message qui tue: « Adobe Photoshop a besoin de Java 6 pour fonctionner, bla-bla, voulez-vous l’installer ? ». Je clique « oui », ça se télécharge, s’installe et PS refuse toujours de démarrer avec le même message.

Je recommence la procédure en me disant que j’ai peut-etre déconné à un moment : même punition, même motif, ça marche pas. Par aquis de conscience, je redémarre le Mac, rien n’y fait.

Ok, j’vais pas me laisser démonter par si peu, je vais voir du côté de chez Oracle et télécharge la version la plus récente (jre-7u45-macosx-x64.dmg), l’installe et… Que dalle ! Là, ça commence un peu à m’agacer.

Je recherche sur internet et, visiblement, je ne suis pas le seul à rencontrer ce genre de problème. En suivant plusieurs liens, j’atterris chez Apple pour récupérer une archive JavaForOSX2013-05.dmg que j’installe illico, et là, joie ineffable, ça marche ! (édition du 12 septembre 2014 : cette archive a disparu du site Apple, j’ai donc supprimé le lien…)

Bref, si vous installez Maverick, pensez à récupérer cette archive et à l’installer, sinon vous risquez quelques surprises. Au passage, j’ai appris qu’Adobe utilise Java pour ses application, j’me coucherai (un peu) moins con.

Publié par

10 réflexions au sujet de « Adobe et Maverick »

    1. C’est, entre autres, parce que j’ai moi aussi mis un bon moment à trouver que j’ai décidé d’écrire cet article. Content qu’il ait servi à quelqu’un d’autre. 🙂

    1. Je me doutais bien que je ne serais pas le seul à rencontrer ce problème, d’où l’écriture de cet article… Ça fait plaisir de voir que j’ai pu rendre service, et encore plus qu’on m’en remercie. 🙂

  1. Le lien direct depuis la fenêtre d’avertissement ne fonctionne pas à cause des restrictions dû au proxy de mon employeur, vous sauvez mon PhotoShop cs5. Milles merci.

  2. après ma mise à jour OSX Maverick, adobe photoshop CS2 ne fonctionnait pas, j’ai réinstaller le logiciel à partir du disque, j’ai téléchargé java mais ça ne marche toujours pas : que faire d’autre? Merc!

    1. Bonjour,

      Je crains que la suite CS2 (datant de 2005) soit totalement incompatible avec Mavericks, car trop ancienne. Selon le site de support d’Adobe, les suites CS3, CS4 et CS5 fonctionnent plus ou moins correctement avec la dernière version de Mac OSX, mais ils n’ont apparemment pas testé la compatibilité de la CS2…

Laisser un commentaire